Back to overview
Downtime

Trust Services Unavailable

May 08 at 05:59pm CEST
Affected services
Identity Services (SPID)
Lean Disposable

Resolved
May 08 at 06:22pm CEST

We have restored services but we are still monitoring and performing a root cause analysis to avoid new issues

Created
May 08 at 05:59pm CEST

We are currently experiencing a service disruption due to an unexpected incident. Our technical team is actively working to identify the cause and restore functionality as quickly as possible.
We apologize for the inconvenience and appreciate your patience.
This page will be updated in the next 30 minutes.