Back to overview
Resolved

Investigation in progress Degradation of IdSelf and IDDoc

Aug 31, 2026 at 1:51pm UTC
Affected services
Trust and Sign - PRODUCTION
PreventGo - PRODUCTION
FaceMatch - PRODUCTION

Resolved
Aug 31, 2026 at 10:11pm UTC

The root cause for the issue about callbacks not being properly sent was fixed at around 20:40 CEST. The situation has been gradually going back to normal, and now the services are fully operational.

We are continuing to monitor the situation.

Created
Aug 31, 2026 at 1:51pm UTC

We have identified an incident affecting our PreventGo and Trust & Sign services, causing disruptions to certain processes and associated workflows.

Several features are currently affected:

  • Document verification and analysis services
  • Webhook delivery

Our technical teams are actively working to resolve this incident.
We will update this page as soon as possible with new information.

Thank you for your understanding.