[Trust and Sign] Incident affecting PVID workflows ONLY
Resolved
Aug 4, 2026 at 10:55am UTC
Dear Customer,
The incident affecting PVID workflows has now been resolved.
Our teams have implemented the necessary corrective actions, and the service is fully operational again.
We apologize for any inconvenience caused and thank you for your patience and understanding.
Affected services
Created
Aug 4, 2026 at 9:55am UTC
Dear Customer,
We would like to inform you that we are currently experiencing a production incident affecting PVID workflows only.
Our teams are fully mobilized and are working to resolve the issue as quickly as possible.
We sincerely apologize for the inconvenience and thank you for your patience and understanding.
Affected services