Back to overview
Degraded
Slower response time on Trust&Sign
Jun 25, 2026 at 8:54am UTC
Affected services
Trust and Sign - PRODUCTION
Resolved
Jun 25, 2026 at 1:15pm UTC
Performance of Trust&Sign and distribution of webhooks is now nominal
Affected services
Created
Jun 25, 2026 at 8:54am UTC
Due to an abnormal amount of traffic, performance and response times on Trust&Sign are slightly degraded. We are investigating the situation and will keep you informed.
Affected services