Back to overview
Degraded
Email Platform Outage
Jun 24, 2026 at 2:01pm UTC
Affected services
Trust and Sign - PRODUCTION
Updated
Jun 24, 2026 at 3:26pm UTC
We are seeing improvements regarding connectivity issues and delays in sending messages. Their engineers are continuing their investigation and are actively working to implement a permanent solution.
Affected services
Created
Jun 24, 2026 at 2:01pm UTC
We are currently aware of a connectivity issue and delays in email delivery on the Trust and Sign email platform. Their teams are currently investigating the matter, and their engineering team is working to resolve the issue. We will keep you informed as soon as we have more information.
Affected services