Back to overview
Degraded

Prevent Go unavailable

Jun 3, 2026 at 2:28pm UTC
Affected services
Trust and Sign - PRODUCTION
PreventGo - PRODUCTION

Resolved
Jun 3, 2026 at 3:42pm UTC

All issues are resolved

Created
Jun 3, 2026 at 2:28pm UTC

A production incident has impacted documents automatic controls on Prevent Go and Trust and Sign.
Begin: 16h28 CEST
End: 17h42 CEST

This incident has been caused by a wrong version deployment that did not succeed.
Our teams were commited to diagnose and solve this issue.

All services are by now fully up.

We sincerely apologize for the inconvenience caused and thank you for your understanding.