Back to overview
Degraded
Issues on Significant.com
Apr 21, 2026 at 7:12am UTC
Affected services
eSAW UI - www.significant.com
File Upload - www.significant.com
REST API - www.significant.com
Resolved
Apr 21, 2026 at 7:30am UTC
Dear customer, our team has resolved the issue and is continuing to monitor the situation. We apologize for the inconvenience.
Affected services
Created
Apr 21, 2026 at 7:12am UTC
Dear customer we are facing some issues on remote signatures in the system, the team is already investigating to solve the situation in the shortest time possible. Next update in 30 minutes
Affected services