Back to overview
Maintenance
PEC Service - Webmail - Hotfix update 0.64.1
Apr 16, 2026 at 4:30pm UTC
–
Apr 16, 2026 at 4:45pm UTC
Affected services
Web Client
Resolved
Apr 16, 2026 at 4:45pm UTC
Maintenance ended
Affected services
Created
Apr 16, 2026 at 4:30pm UTC
Graphical hotfix. No downtime expect
Affected services