Issues on Saas.esignanywhere.net
Resolved
Apr 16, 2026 at 2:39pm UTC
Our team has resolved the issue with greater speed than anticipated, and the system is already operational. We sincerely apologize for the inconvenience caused. We will continue with constant monitoring of the platform and implement the corrective actions necessary to prevent the recurrence of the same problem.
Affected services
Created
Apr 16, 2026 at 2:33pm UTC
Dear customer we are having some issues on the service and the team is already on it, the next update will be in 30 minutes.
Affected services