Back to overview
Degraded
Mutliple service degradation
Mar 04, 2026 at 08:04am UTC
Affected services
Onboarding API
Resolved
Mar 04, 2026 at 09:33am UTC
The issue is completely resolved. All the systems are now working nominally
Affected services
Updated
Mar 04, 2026 at 08:51am UTC
The resolution has been implemented and it's propagating to all the services. We're actively monitoring the situation.
Next update in one hour.
Affected services
Updated
Mar 04, 2026 at 08:34am UTC
We've identified the source of the issue and we're implementing an immediate resolution
Affected services
Created
Mar 04, 2026 at 08:04am UTC
We're experiencing degradation on some services. Our engineers are actively working to diagnose and solve the issue.
Affected services