E-mail delivery delayed on eSAW
Resolved
Sep 30 at 12:32pm CEST
We solved the issue in saas.esignanywhere.net and www.significant.com, all the new envelopes will be sent immediately, old ones are still delayed and will be processed as soon as possible, we apologize for this issue.
Affected services
Updated
Sep 30 at 12:09pm CEST
The issue is identified by our technical team, we are working to solve it and we expect the resolution soon. Next update in 30 minutes.
Affected services
Created
Sep 30 at 11:27am CEST
Hi, we are having a delay in sending signatures emails, we are already investigating the issue. Next update in 30 minutes
Affected services