Back to overview
Degradation in Shop PEC
Sep 11 at 03:19pm CEST
Affected services
Shop PEC
Resolved
Sep 11 at 03:43pm CEST
We have found and resolved the issue
Affected services
Created
Sep 11 at 03:19pm CEST
We are experiencing delays in queue management for the PEC shop, leading to longer wait times.
All functionalities are operational, and there are no service disruptions. We are working to resolve the issue and will provide updates.
Thank you for your patience.
Affected services