Back to overview
Degraded
Problems to upload and download files
May 28 at 05:25pm CEST
Affected services
PCT Enterprise
PCT Namirial
Resolved
May 28 at 06:31pm CEST
This incident has been resolved.
Affected services
PCT Enterprise
PCT Namirial
Created
May 28 at 05:25pm CEST
We're having trouble accessing storage. We're having trouble uploading and downloading files
Affected services
PCT Enterprise
PCT Namirial