Back to overview
Degraded
Service Disposable Lean
Jul 09 at 01:21pm CEST
Affected services
Lean Disposable
Resolved
Jul 09 at 01:47pm CEST
This incident has been resolved.
Affected services
Lean Disposable
Updated
Jul 09 at 01:33pm CEST
A fix has been implemented and we are monitoring the results.
Affected services
Lean Disposable
Created
Jul 09 at 01:21pm CEST
We are currently experiencing technical issues with our disposable signature service. Our engineering team is actively working to resolve the problem. Thank you for your patience.
Affected services
Lean Disposable