Back to overview
Resolved

Instability of the Prevent and Trust and Sign services

Sep 14, 2026 at 9:38am UTC
Affected services
Onboarding API eu-ie1
Onboarding API eu-fr2
Trust and Sign - PRODUCTION
PreventGo - PRODUCTION

Resolved
Sep 14, 2026 at 1:25pm UTC

Dear customers,

We are pleased to inform you that our services are now fully operational and that the slowness and delays previously reported have been resolved.

Thank you for your understanding.

Updated
Sep 14, 2026 at 11:18am UTC

Dear Customers,

We are pleased to inform you that the Prevent and Trust and Sign services have now been restored for all document checks.

However, some slowness or delays in the processing of video FaceMatch checks may still be experienced, while the pending identifications are processed. A return to normal service is expected by 2:50 PM.

Thank you for your understanding.
Best Regards,

Updated
Sep 14, 2026 at 11:04am UTC

Dear customers,

Kindly note that the degradation impacting Trust and Sign and Prevent on the Production platform is still ongoing.

Our teams are actively working on recovering the situation and we will provide more information when available.

Thank you for your understanding.

Created
Sep 14, 2026 at 9:38am UTC

Dear customers,

We are experiencing a degradation of Prevent and Trust and Sign solution.

A portion of the requests are failing.

We are working to restore full operation.
Estimated start time: 11h38

Thank you for your understanding.

Best Regards