Back to overview
Resolved

Degradation of Prevent and Trust and Sign services

Sep 11, 2026 at 8:46am UTC
Affected services
Trust and Sign - PRODUCTION
PreventGo - PRODUCTION

Resolved
Sep 11, 2026 at 8:46am UTC

An issue affecting document submissions occurred between 6:55 AM and 10:40 AM. The issue has now been resolved, and everything is back to normal. We are continuing to monitor the situation closely.