Back to overview
Resolved

Degradation of IdSelf and IDDoc

Sep 1, 2026 at 6:40am UTC
Affected services
Onboarding API eu-ie1
Trust and Sign - PRODUCTION
PreventGo - PRODUCTION
FaceMatch - PRODUCTION

Resolved
Sep 1, 2026 at 10:24am UTC

Dear Customer the incident is now solved and the situation is back to normality, we'll continue to improve our services in order to avoid future problems. We also would like to apologize for the inconvenience this may have caused.

Updated
Sep 1, 2026 at 9:44am UTC

Dear customer, we are continuing to monitor the situation and fine-tune the system. We will provide the next update in 45 minutes.

Updated
Sep 1, 2026 at 9:11am UTC

Dear customer the team rolled out an application fix which is showing us sensitive improvements on the overall performances, we continue to monitor the situation until we are sure there are no issues at all and all the queues are correctly managed. The next update will come in 30 minutes.

Updated
Sep 1, 2026 at 8:20am UTC

Dear customer, our first approach to the resolution was not successful and we are still investigating the root cause but it is taking more time than expected, the next update will be provided in 60 minutes.

Updated
Sep 1, 2026 at 7:49am UTC

The team is now investigating one component that is not performing as expected, we'll provide an update within 30 minutes.

Created
Sep 1, 2026 at 6:40am UTC

We are currently investigating a degradation on IdSelf and IDDoc services.
We will keep you informed of any further developments.

The Namirial Team