Back to overview
Resolved

Degraded response time on PreventGo / IdDocCheck / IdSelf services

Aug 31, 2026 at 9:30am UTC
Affected services
PreventGo - PRODUCTION

Resolved
Aug 31, 2026 at 9:56am UTC

We have fixed the root cause of the issue. PreventGo / IdDocCheck / IdSelf services are now fully operational

Updated
Aug 31, 2026 at 9:51am UTC

We identified a possible root cause of this issue. We are working on a fix.

Created
Aug 31, 2026 at 9:30am UTC

Our team is still still working on resolving the situation. We will keep you informed of any further developments.