Issues regarding SWS SaaS
Incident Report for Namirial
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 15:48 CEST
Investigating
We are noting the unreliability of SWS service by our customers. Our engineering team is working to resolve the situation as quickly as possible. Updates to come soon
Posted Oct 14, 2024 - 15:32 CEST
This incident affected: Trust Services (SWS SaaS).