Release of eSignAnyWhere - significant.com failed - Rollback in progress
Incident Report for Namirial
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 05:00 CEST
Identified
We encountered a severe problem during tonight's update and now have to rollback the system to a previous state.
This activity will take a few more hours.

We apologize for any inconveniences!
Posted Jul 15, 2024 - 23:52 CEST
This incident affected: eSignAnyWhere - significant.com (eSAW UI (significant.com), Viewer UI (significant.com), REST API (significant.com)).