PEC Service - Proxypec - Scheduled update 3.0.0
Scheduled for Jan 15, 2025, 22:00 - 23:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 08, 2024 - 09:43 CEST
Scheduled
Security fix.
No downtime expected.
Posted Oct 04, 2024 - 09:14 CEST
This scheduled maintenance affects: PEC (Web Client).